Arkusz kalkulacyjny w służbie prosumenta

W tym artykule pokażę jak stworzyć prosty arkusz kalkulacyjny, który pomoże kontrolować bilans rozliczeń na net-billingu. Jest też opcja dla wygodnych – umieściłem na dole strony link do gotowego pliku xlsx: wystarczy ściągnąć podmienić dane i korzystać. Plik jest stworzony w Excelu ale próbowałem go również otworzyć w Libre Office i Arkuszach Google. Poza drobnymi różnicami w nagłówkach wszystko działa jak należy.

Dla tych co nie chcą iść na skróty ostrzeżenie: strona ta nie będzie się dobrze wyświetlać na urządzeniach mobilnych. Jeżeli chcesz koniecznie, przeglądać ją na smartfonie należy robić to w widoku poziomym.

Tworzymy plik z dwoma arkuszami kalkulacyjnymi. Pierwszy nazwiemy BILANS, drugi POBRANA. Naszą tablicą, pulpitem jest arkusz bilans. Arkusz pobrana służy tylko do przeliczania i aktualizacji danych. Wypełnimy go tylko raz wstawiając ceny energii pobranej czynnnej w kolumnie C oraz koszty dystrybucji w kolumnie D. Pozostałych kolumn nie ruszamy. Dane w kolumnie B są zaciągane z arkusza bilans a wartość energii czynnej pobranej i kosztów dystrybucji są przeliczane automatycznie.

Arkusz I – BILANS

  • kolumna A – miesiące
  • kolumna B – energia pobrana
  • kolumna C – energia oddana
  • kolumna D – wartość energii oddanej (pobrana * cena RCEm/1000)
  • RCEm/1000 – cena RCEm przeliczona za 1kWh

Po wprowadzeniu wszystkich danych w wierszach 2-19 w wierszu 20 sumujemy kolumny B,C i D. Następnie wpisujemy w wybrane pola odpowiednie funkcje:

  • pole C22 – kopiujemy wartość z pola D20 (wartość energii oddanej)
  • pole C23 – kopiujemy wartość z pola E20 z arkusza pobrana (wartość energii pobranej)
  • pole C24 – różnica pomiędzy wartością tego co oddaliśmy a tego co pobraliśmy C22-C23. Jeżeli wyjdzie wartość ujemna mamy dług.
  • pole C26 – produkcja (dane z falownika)
  • pole C27 – produkcja minus energia oddana
  • pole D27 – stosunek autokonsumpcji do całkowitego zużycia energii. Jeżeli komórkę D27 sformatujemy jako procentową otrzymamy wartość w procentach
  • pole C28 – całkowite zużycie energii czyli pobrana + autokonsumpcja
  • pole C30 – koszty dystrybucji (kopia pola F20 z arkusza pobrana

Dalsza część instrukcji pod tabelką.

 

A B C D E
1 POBRANA kWh ODDANA kWh WARTOŚĆ ODDANEJ RCEm/1000
2 lipiec 2022 130,221 1170,260 =C2*E2 0,79627
3 sierpień 2022 167,675 1049,997 =C3*E3 1,01906
4 wrzesień 2022 184,100 766,182 =C4*E4 0,71003
5 październik 2022 373,510 563,050 =C5*E5 0,57635
6 listopad 2022 824,194 196,434 =C6*E6 0,70520
7 grudzień 2022 644,471 55,315 =C7*E7 0,71680
8 styczeń 2023 =C8*E8
….. ….. ….. ….. ….. …..
19 grudzień 2023 =C19*E19
20 SUMA: =SUMA(B2:B19) =SUMA(C2:C19) =SUMA(D2:D19)
21
22 wartość energii oddanej: =D20
23 wartość energii pobranej: =POBRANA!E20
24 pozostało w depozycie: =C22-C23
25
26 produkcja w kWh: 5400
27 autokonsumpcja : =C26-C20 =C27/C28
28 całkowite zużycie energii =B20+C27 1
29
30 koszty dystrybucji: =POBRANA!F20
31

Po prawidłowym wypełnieniu obydwu arkuszy nasz Bilans powinien wyglądać tak jak na załączonym screenie. Mamy tu wszystkie najważniejsze zmienne:

Arkusz II – POBRANA

W tym arkuszu zapełniamy danymi tylko kolumny D i E. Pozostałe pola wypełniamy funkcjami. Przygotowany prawidłowo, powinien ilość energii pobranej automatycznie zaciągać z arkusza Bilans.

A B C D E F
1 POBRANA: CZYNNA kWh/zł DYSTRYBUCJA kWh/zł CZYNNA WARTOŚĆ DYSTRYBUCJA WARTOŚĆ
2 lipiec 2022 =BILANS!B2 0,312795 0,2244 =B2*C2 =B2*D2
3 sierpień 2022 =BILANS!B3 0,312795 0,2244 =B3*C3 =B3*D3
4 wrzesień 2022 =BILANS!B4 0,312795 0,2244 =B4*C4 =B4*D4
5 październik 2022 =BILANS!B5 0,312795 0,2244 =B5*C5 =B5*D5
6 listopad 2022 =BILANS!B6 0,503931 0,2244 =B6*C6 =B6*D6
7 grudzień 2022 =BILANS!B7 0,503931 0,2244 =B7*C7 =B7*D7
8 styczeń 2023 =BILANS!B8 0,858540 0,364326 =B8*C8 =B8*D8
9 luty 2023 =BILANS!B9 0,858540 0,364326 =B9*C9 =B9*D9
10 marzec 2023 =BILANS!B10 0,858540 0,364326 =B10*C10 =B10*D10
11 kwiecień 2023 =BILANS!B11 0,858540 0,364326 =B11*C11 =B11*D11
12 maj 2023 =BILANS!B12 0,858540 0,364326 =B12*C12 =B12*D12
13 czerwiec 2023 =BILANS!B13 0,858540 0,364326 =B13*C13 =B13*D13
14 lipiec 2023 =BILANS!B14 0,858540 0,364326 =B14*C14 =B14*D14
15 sierpień 2023 =BILANS!B15 0,858540 0,364326 =B15*C15 =B15*D15
16 wrzesień 2023 =BILANS!B16 0,858540 0,364326 =B16*C16 =B16*D16
17 październik 2023 =BILANS!B17 0,858540 0,364326 =B17*C17 =B17*D17
18 listopad 2023 =BILANS!B18 0,858540 0,364326 =B18*C18 =B18*D18
19 grudzień 2023 =BILANS!B19 0,858540 0,364326 =B19*C19 =B19*D19
20 SUMA: =SUMA(E2:E19) =SUMA(F2:F19)
21

Poniżej screen prawidłowo przygotowanego arkusza POBRANA.

Gotowy plik do ściągnięcia:


Related Posts

Begin typing your search term above and press enter to search. Press ESC to cancel.